Tuesday, July 16, 2013

Distro Hopping Update

So, where does one turn in Linux to have things work out?

Those are my requirements:
  1. Good out-of-the-box experience: the install, GUI, default programs must be sane. All codecs and flash player need to be included. HP driver support needs to be integrated. The sane default programs include a good IRC client, a proper browser (i.e. Firefox or Chromium), a proper email client (i.e. Thunderbird).
  2. Good software repositories: I need to be able to install everything I want without struggle
  3. MTP support: I need to be able to just plug in my recent Android devices and have it mounted automatically. That means a reasonably recent version of KDE or the latest Gnome.
  4. Good desktop widgets: I need a CPU, RAM and heat monitor, a weather indicator, and a keyboard layout switcher
  5. Easy launcher. I should be able to launch a program with only 2-3 keystrokes (except for the typing of said program's name, of course)
  6. No 3d. The desktop must run without OpenGL and needs to be smooth (and use very little CPU doing so)
  7. Very stable
  8. No major updates or very easy updates. That gives a bias towards rolling distributions.
  9. Security updates are all available very very fast.
  10. EDIT Plugging to a TV using an HDMI cable should have both the video and the audio automatically sent to the TV.

You will notice this weird 'no 3d' requirement - that is because my video card isn't well supported by Intel drivers. I observed a significant improvement in stability since I am using 2D only desktops.

That automatically removes any Cinnamon desktop, as even the 2D version is a CPU hog. KDE is a mixed bag, especially regarding the KDE wallet that is essentially ruining the experience for everyone that doesn't know how to make it behave. Gnome Fallback Mode on older versions is OK (only underwhelming). My understanding of Gnome Classic on the latest version is still relying on 3D. When it comes to SSH keys, Gnome keyring daemon has been the best option I experienced so far.

You will note that my judgment comes very quickly. I have no time for customizing something for hours. That is also why I'm sticking with the big DEs - Gnome, KDE, XFCE. I am sure Englightement is amazing, but I also don't feel like customizing for hours. Same with a plain Arch.

What about the major distributions?
  • Debian, Ubuntu, Fedora, OpenSUSE, Mageia : No codecs pre-installed. That is a bummer. I understand the need for legal CYA, but end-users don't care. They want their Youtube kittens, and they want 'em NOW.

So we need to go to distributions derived from those. How are they faring? I tried all of those in VirtualBox with a 8 Gb virtual drive and 1 Gb RAM.
  • Scientific Linux: Very very old software (Kernel 2.6, Gnome 2). Will not support MTP. Takes a ton of space to install.
  • Mageia: I decided to give this one is a go at a friend's suggestion. It looks like a plain Gnome offering.
  • Korora: This spin of Fedora is pretty decent. The folks on IRC are super helpful. The downside is that the update will have to go through's Fedora's pain.
  • Manjaro: This Arch-based distro is pretty good. But installing Oracle's JDK from AUR was breaking for me on the VM. I generally found using yaourt to be veeeeery user-unfriendly.
  • Linux Mint 15 MATE: Slick-looking, but the start menu is annoying. I can type the name of the program I want to run, have it found, but I need to click. Grr.
  • LMDE: LMDE doesn't guarantee to be up-to-date on security updates. That is the only thing going against this option.
So, right now, I am running Korora with KDE. I have made it behave and I appreciate the help from the folks on IRC. I wouldn't mind Manjaro at some point, but I need to see a real good package manager installed by default to deal with the AUR.

Wednesday, May 8, 2013

English Vinglish

English Vinglish is the story of a neglected and belittled housewife/entrepreneur who decides to take English classes while she is in New York.

It helps you understand how people feel when dealing with a language barrier, and the kind of value/stigma that Indian society puts around a good knowledge of the English language.

This is the only movie that required both French -> English and Telugu -> Translation I ever saw.

It is a good clean family movie that I really recommend.

For Rebellious Screen Backlights

I had a problem on every Linux distro I ever used on this specific laptop. The light setting wouldn't change, no matter how much I pressed on the designated buttons.

On the #korora IRC channel, I got this very good tip from csmart I thought I should share:

As an administrator, open /etc/default/grub, and then locate the line that starts with GRUB_CMDLINE_LINUX. On that line, inside the quotes, add "acpi_osi=Linux acpi_backlight=vendor" (no quotes) and then you need to refresh your grub information and finally reboot.

You can get more information on the Arch Wiki.

Wednesday, May 1, 2013

openSUSE is Configuration Torture

I was having a lot of crashes with Linux Mint 14 on my laptop, so I considered trying a distro I didn't try yet. So I went for openSUSE. I regret it.

First, you notice that the wi-fi isn't enabling. This is very weird, because the live CD had it working out of the box. I had to turn on some option in YaST and then things went back to normal. This was a warning of things to come...

Then, there are crazy instructions to install JDK. Your eyes may bleed. So I did what any self-respecting geek would do, I installed the RPM from Oracle, and put together a script to automate the alternative-setting. However, that script isn't perfect and it gave me trouble trying to build LibreOffice.

The pain wasn't over. There are 3 interfaces to set up an HP printer - YaST, the KDE gui, and HP-Setup. Which one should you use? The right answer is HP Setup - not obvious. But if its a non-HP one, then you have to use YaST.

Note that you may need to reconfigure your firewall if you have a network printer. Instructions to do so are pretty unclear, and there is no wizard/magic GUI to do it for you.

Then, there is the fact that the SSH key/password daemon is not supplied out of the box. You need to install ksshaskpass. But the official package doesn't install. But, lucky you, the unofficial one does work.
But that doesn't make it enabled yet, you need to mess with many configuration files.

TrueCrypt doesn't work out of the box, so you need to mess with another configuration file.

Skype didn't work out of the box either, I had to manually pick the audio settings.

And, weirdly, I don't see any pop-up telling me to install updates, which the live CD was showing. No, you need to install an applet for that. But wait, it conflicts with Apper. Waaaaaaaaaaaaaaaaaaa? Oh, and even funnier: YaST doesn't update all the repos you have set up, so you end up using two package managers. Double WAT!

If I wanted this kind of pain, I'd have installed Arch. And I'm doubting that Arch may be more sane...

I seriously can't recommend this distribution for my friends and family. The ease of setting up a printer in Ubuntu/Mint and Fedora is leagues ahead of openSuse. And as a sidenote, I'm not sure I actually got my printer to work reliably yet.

And about those stability issues? Well, I got a few crashes and freezes too...

My gut feeling right now is that I'll install Mint 15 when it is released this month.

Thursday, March 14, 2013

Google Reader Closure

Man!!!

I have been consistently reading my news from Google Reader and keeping an offline copy to read when I'm offline.

I saw some options online, but I wasn't too happy:

  • NetVibes doesn't have an Android app, so that's online only
  • NewsBlur's free account allows you to follow 12 feeds only. Are your crazy??? On the plus side, the android app looks like it works offline.
  • Feedly has an android app and unlimited feeds, but no offline support.
It looks like the only real option is  Tiny Tiny RSS - it has an android app that syncs with the server, but you have to host it yourself. Grrr...

I'm sort of hoping that either Feedly gets an offline mode, or someone sets up public Tiny Tiny RSS access at this point.

Saturday, January 5, 2013

Building LibreOffice with Clang on Ubuntu/Mint

So, I wanted to build a clang plug-in for LibreOffice. I never expected that it would be hard to do so.

I am on Linux Mint 14, and the problem was that the clang/llvm version is slightly older.

So, here is how I made it work (thanks to the guys in the mailing lists).
  1. Install the clang ppa: https://launchpad.net/~dr-graef/+archive/llvm-3.1.quantal
  2. Update your package cache: sudo apt-get update
  3. Install clang: sudo apt-get install clang llvm
  4. (optional - if you want to build plug-ins) sudo apt-get install llvm-dev libclang-dev
  5. Add the following to your autogen.lastrun file: CC=clang
    CXX=clang++
    --enable-compiler-plugins (that last one only if you want to build the plug-ins)
  6. Run ./autogen.sh && make  and you are in business.
The rest of the discussion is available on the wiki.